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Introduction to QGIS 
Practical Exercise 2 

 

This exercise builds on Exercise 1B. The data you’ve prepared and styled in the 
previous practical, will now be used to compose and publish a final map. 
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 Ms. Elena Flórez -  Junior scientist, Agencia Estatal de Meteorología, Spain 

 

 Mr. Courtney Forde - Intern, CIMH, Barbados 
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1 Creating Maps in QGIS 

Your data rendered in QGIS may easily be illustrated in the form of a map by 
using the Print Composer tools located under the [Project] menu. The 
following sub-sections demonstrate how to use the Print Composer to 
generate a map similar to that illustrated below. Launch your saved project from 
Exercise 1B and let’s begin. 
 

 

 

1.1 Changing the Coordinate Reference System of a Project 

 

Your final map will have a scale bar which, by default, reflects the 
scale/size/distances of rendered map objects in the units used by the map. 
Currently, the project uses a Geographic Coordinate System known as the 1984 
World Geodetic System (WGS 84). Objects rendered in WGS 84 are 
measured in decimal degrees. If you were to create a map using the project’s 
current coordinate reference system, the units of the scale bar would be in 
decimal degrees. Ideally, your scale bar should be in units such as miles, 
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metres or kilometres so that the scale information is more useful to viewers. 
Therefore, before you start composing your final map, you must change the 
project’s coordinate reference system from a Geographic Coordinate System to 
a Projected Coordinate System that uses metres. 
 

1. Select {Project Properties...} from the [Project] menu. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
2. Select the CRS tab from the left panel; activate “Enable „on the fly CRS‟ 

transformation” and select “World Mercator” from the list of “Recently 
used coordinate reference systems” (see image above). 
 
 
Note: If for any reason, the “World Mercator” coordinate reference system is not 

listed, then simply locate it using the Filter field. Type “World Mercator” into the 

field and the coordinate system will be appear at the bottom of the menu as shown 

in the following image. 
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3. Hit {OK} after the World Mercator coordinate system has been selected. 

Note: The coordinate reference system of your project has now been changed 

from WGS84 (a geographic coordinate system) to World Mercator (a projected 

coordinate system); so now when you apply a scale bar to your final map, it will 

represent map objects in units of metres or kilometres. 

 

1.2 Setting Up the Map Page  

 

1. Select the [Project] menu and choose {New Print Composer} from the list.  
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Note: This launches a “Composer title” menu, where you are invited to give your 

map composition a title. 
 

2. Enter the name, “Australia - 24 Hour Temperature Forecast (20140717)”, 
into the field and hit {OK}. 
 

Note: A second interface, as illustrated by the 

following image, will open up and display the 

Map Composer (see next image). This 

interface is used to construct and 

publish/export the final map.  
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3. Your first step will be to set the map/composition layout. Start by activating 
the Composition tab (see next image) on the right portion of the Print 
Composer screen.  
 

4. Under “Paper and quality”, select A4 (210x297mm) from the “Presets” 
drop-list; browse down to “Orientation” and select “Landscape” from the 
drop-list if it is not already selected by default (see next image). 
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Note: These settings determine the dimensions and orientation for your final map. 

Now you‟ll import the contents of the Map Canvas for your final graphic. Before 

doing so, enable the grid option (see previous image) to help you to assess how your 

map objects are aligned. To do so, select the [View] menu option and enable {Show 

Grid}. 
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1.3 Adding Map Content 

 

1. Select the [Layout] menu option and choose the {Add Map} tool from the 
list.  
 

 

 

Note: Alternatively, you may use the {Add new map} tool from the toolbar on 

the left of the interface – see image on the left 

 

2. Place your mouse over a random area in the top left-corner of the 
map composition page; left-click and drag your mouse towards the top 
right-corner and then down towards the bottom-right. When you release 
the mouse, the map content will appear. 

Note: Do not be concerned at the moment if your map appears to be too big or 

too small for the page. These issues will be adjusted in further steps. 
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3. Activate the Item Properties tab on the right of the screen (see next 

illustration) and scroll down to the fields under “Position and size”. 

Note: This is where you are allowed to set the size of the map frame. Currently the 

composition page is 297 mm X 210 mm. The aim is to make the map frame just 

slightly smaller than the composition page. 

 

4. Set the Width 
and Height fields 
under “Position 
and size” (see next 
illustration) to 295 
mm and 208 mm 
respectively.  
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Note: You can use your mouse to drag the map frame to the centre of the composition 

page. 

 

5. Scroll to the 
section below 
“Rotation” and enable 
the “Frame” option to 
make the map frame 
visible. 

 

Note: For now, allow the 

frame properties to remain 

at their default settings. 

However, frame colour, 

frame thickness and “join 

style” settings can be 

changed via this part of 

the menu.    
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Your map content is now in place. However, its size on the page may need to be 

adjusted to make a better composition. You can adjust it by doing the following: 

 

1) Return to the main QGIS window and set the map to the full extent with 

the Zoom Full tool. 

 

2) Return to the Map Composer window and see if this the size in the Map 

composer has improved. Follow step a, if your map is still too small for the 

page. However, if your map is too large on the page, then skip step „a‟ 

below and follow step „b‟. 

 

a. Do the following: 

 

i. Return to the QGIS main window and activate the Zoom in 

tool. 

 

ii. Click on a section that is northwest of Australia; drag your 

mouse to the right and stop at an area that is northeast of 

Australia; then drag to the south and release. This creates a 

box around the country which defines the area that QGIS 

will zoom to. The level of zoom will be determined by the size 

of the box you make.   

 

b. Do the following: 

 

i. Return to the QGIS main window and activate the Zoom out 

tool. 
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ii. Use the Zoom out tool to decrease the size of the map. The 

Pan tool may also be used to re-centre the map. If you‟ve 

zoomed out too far. Then simply use the Zoom in tool to 

adjust the size. 

 
3) Return to the Map Composer window; activate the Item Properties 

tab; scroll to the “Extents” section (see image below) and select, 
“Set to map canvas extent”.  

 

 

 

 

 

 

 

 

 

 

 

 

 

The aim is to change the map content so that its size on the page is similar to that 

shown in the next image: 
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4) If you are not satisfied with the changes you’ve made to the map so 
far, you can repeat steps 2 and 3 above until you get an outcome that 
is similar to the image seen above.   

 

The scale bar, legend, north arrow and map title may now be added to complete 

your map. Before doing so, try the following: 

 

1) Select the [Layout] menu option and then choose {Move Content}.  

Tip: The Move Content tool  may also be activated from the toolbar.  
 

2) Place your mouse over any random region of the map content; left-click, hold 

and drag the image around the composition page.  
 

Note: This tool allows you to shift the map content around the composition 

page without moving the frame. This may become necessary as you add more 

objects (i.e. scale bar, legend, north-arrow and map title) to your composition 

page. Once you‟ve finished experimenting with this tool, return the graphic to 

a central location on the page.  

 

1.4 Adding a Scale Bar 

 
1. To add your scale bar, select the [Layout menu] and then select {Add 

Scalebar}. 

Tip: The Add scalebar tool   may also be activated from the toolbar. 
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2. Position your mouse on any area of the composition page (with white space) 
and then double-click to add the scalebar. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Note: A scalebar should now be visible on the composition page, showing distances in 

kilometres. Had the steps in section 1.1 not been taken, the scalebar you just added 

would have defaulted to units of decimal degrees. By changing the coordinate 

reference system associated with the project to a projected coordinate system that uses 

units of metres instead of decimal degrees, your scale bar is now more appropriate. 

QGIS can easily convert the native units of the scalebar (metres) to other types of 

units such as nautical miles or feet if so desired. This option is demonstrated in the 

next steps.  
 

3. Activate the Select/Move item tool  from the toolbar. 

 

4. Single-click your scalebar to ensure it is selected; then activate the Item 
properties tab (see next illustration) on the right. 
 

5. Locate the “Main properties” section under the current tab and select the 
Style drop-list (see next illustration). 
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Note: You should now see a list of styles that may be applied to your scalebar. Try selecting 

different scalebar styles and observe the changes. Set your final choice to the “Double Box” 

style and then proceed. 

 

6. Scroll down to the section of the interface captioned, “Units” (see next 
illustration). 

 

Note: Under 

“Units”, there is a 

drop-list and two 

fields captioned, 

“Label” and “Map 

units per bar unit”. 

The former field is 

used to change the 

label that is 

assigned to the 

scalebar. Try 

changing the entry from “km” to “kilometres” and see what happens. The other 

field simply controls the ratio of map units to scale bar units. The default setting is 

ideal given that the ratio of metres (the native map units) to kilometres is 1000:1. 

If you wanted to, you could also change the native map units from metres to 

nautical miles or feet by selecting from the drop-list in this section of the menu. 
 

7. Scroll down to “Segments” (see next illustration); experiment with the 
available fields and see what happens.  
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Note: Before moving on, set the left segment to 0 and the right segment to 4. The 

size and height fields can be left at their default values. 
 

8. Scroll down to 
“Fonts and 
colors” (see 
next 
illustration) and 
experiment with 
the font and 
colour options 
for your scale 
bar. 

Note: Make sure 

to finalise your 

scalebar using a 

black Arial font in Bold and size 12. When completed, use the {Move Content} and 

{Select/Move Items} tools to reposition the objects on the composition page so that 

they resemble the following graphic.  

 

Tip: The map content can only be shifted with the {Move Content} tool. However, 

you must first select it with the {Select/Move items} tool. 
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The next step illustrates how to add a map legend. 

1.5 Adding a Legend 

 

1. Choose {Add Legend} from the [Layout] menu; double-click any random 
location on the composition page to make your legend appear. 
 

Tip: You may also use the {Add legend} tool   from the toolbar. 
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Note: When your legend is added, it will appear quite large on the page. This is 

because of the way the cities layer is classified and the large number of cities in 

your map. However, since the cities are labelled then you will not need to show 

them in the Legend. They will be removed in due process.  

 

2. Use the {Select/Move item}  tool to select the Legend. 
 

3. Once the legend object is selected, activate the Item properties tab on the 
right. 
 

4. Locate the “Main properties” section and view the entry in the “Title” field 
(see next illustration).  
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Note that changes to this field will result in changes to the title of the legend in 

your map. However, you should retain the default title for now.   
 

5. Scroll down to “Legend items” (see next illustration). 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Note: This section lists all the data layers currently present in your map. From this panel you 

can control which layers are shown in the legend and also how legend entries are labelled 

and styled. You will take this opportunity to remove the cities layer from the Legend. 
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6. Disable the “Auto update” option, highlight the cities layer 
(“Australia_Cities_Selected_WGS84”) and then select the {Delete} tool 
(see next illustration). 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Note: Using the delete entry tool on a selected Legend item will remove it from the 

Legend. After this step, your map should now resemble the following image. Notice 

the Legend has been updated to show the removal of cities.  
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7. Use the same method from the previous step to remove the country layer 
(i.e. “Australia_WGS84”) from the Legend.  

Note: Next, you‟ll experiment with the characteristics of the legend entry for 

temperatures.   

 
8. Select/Highlight the temperatures layer in the Legend items menu and then 

select the edit tool (represented by the pen and pad graphic shown in 
the next image) 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Note: This launches a “Legend item properties” menu, where you can change the 

label/name assigned to a legend entry.  

 

9. Change the entry in the Legend item properties menu from its default to 
“Temperature (Degrees Celsius)” and hit {OK}.  
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Note: The entry in your legend should have been renamed. The new name is now 

easier for viewers to interpret. 

 

10. Use the {Select/Move items} tool to shift the Legend into a new 
position on the map, similar to that which is illustrated below. 
 

 

Note:  Your decision to include or exclude layers from your map legend should be 

dependent on the message your map is intended to communicate and also the 

perceived role the features play in getting the message across. In this case, the 

map has a simple purpose of communicating the spatial distribution of 

temperatures according to a 24-hour modelled forecast. Since the cities are 

labelled there would be no need to include them in the Legend. The country layer 

is also not needed to help tell the story.  

 

The next steps deal with changing the font styles and spacing associated with your 

legend entries. 
 

11. Scroll down to “Fonts” and try changing the Title font, Subgroup font and 
the Item font.  
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Note: Finalize your Legend with a size 16 Arial font in Bold for the Title, a size 12 

Arial font in Bold for the Subgroup font and a size 12 Arial font in Bold for the 

Item font..  

 

12. Scroll down to “Symbol” (see next image) and change the symbol width to 15 
mm. 

 

 

 

 

 

 

 

 

 

 

 

13. Scroll down to “Spacing” (see next image) and experiment with changing 
all the options to see the effects caused. 
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Note: Your final changes should be as follows: 

 Title space – 3.00 mm 

 Group space – 2.00 mm 

 Subgroup space – 6.00 mm 

 Symbol space – 2.00 mm 

 Icon label space – 5.00 mm 

 Box space – 2.0 mm 

 Column space – 2.0 mm 
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1.6 Adding the North Arrow 

 

1. Select {Add Image} from the [Layout] menu and click in an open space on 
the composition page. 

Tip: The {Add image} tool  may also be activated from the toolbar.  

 
2. Activate the Item properties tab on the right and scroll to “Search 

directories”. 
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Note: A set of preview images will load from a directory on your system. You will need 

to choose an appropriate image from this list to be used as your north arrow. Unlike 

other GIS platforms, QGIS is quite limited in the types/styles of north arrow graphics 

it provides. However a few suitable options can still be found.  
 

 

 

 

 

 

 

 

 

 

 

 

 

3. Select the north arrow (shown above) from the list and then scroll to 
“Position and size” (see next illustration). 
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4. Change the Width and Height field entries from their default sizes to 45 and 
43 to slightly increase the dimensions of the north-arrow. 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 

Note: The map is almost complete. All it needs now is a title and some final minor 

adjustments.. 
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1.7 Adding a Map Title  

 

1. Select the {Add Label} tool from the [Layout] menu and single-click the 
upper section of the composition page. 
 

Tip: The {Add Label} tool  may also be selected from the toolbar. 
 

 

2. Activate the Item properties tab and enter the title “24-Hour Temperature 
Forecast (July 17 2014)” under the Main properties text field (see next image).  
 

 

 

 

 

 

 

 

 

 

 

 

 

3. Scroll down to 
“Appearance” (see 
image on the right) and 
apply a Bold Arial font 
in size 24. Also set the 
horizontal alignment to 
“Center” and the 
vertical alignment to 
“Middle”. 
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Note: Use the Select/Move items tool to shift the map title to a position that is 

similar to that shown in the image below. 

 

 

 

1.7 Making the Final Adjustments  

 

Note: All of the necessary map elements have been created. However, there are 

perhaps some final adjustments you can make to improve your map. For example, 

you may need to consider shifting items around the page with the {Select/Move item} 

and {Move Content} tools to make the page look more balanced or to avoid clashes 

with other map objects. Please note that it is also possible to shift an object around the 

composition page using the arrow keys on your keyboard, once it has been selected 

with the {Select/Move Item} tool. You should also remember that the map content 

(map of Australia) can only be shifted around by using the {Move Content} tool.  

 

Another thing you may have to consider is whether the size of your city points and 

their label sizes are suitable. Changes you make in your main QGIS Window may not 

be automatically reflected in the Map Composer. However you can update the Map 

Composer window by doing the following after you‟ve changed layer properties (i.e. 

sizes, colours, etc.): 

 

1) Return to the Map Composer 
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2) Use the Select/Move Item tool to select the map frame 

 

3) Open the Item Properties tab and locate the “Main properties” section 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

4) Select “Render” from the drop-list and then hit “Update preview”. 

 

These steps will update the Map Composer to reflect any changes you‟ve made in the 

QGIS main window. So for example, if you‟ve changed any of the sizes or colours for 

symbols or their labels, the changes would be visible in the Map Composer, after you 

hit the “Update Preview” button. If necessary, you should experiment with some 

changes in the main QGIS main window to increase the sizes for the symbols for the 

various cities. You should also consider changing the label sizes.  

 

Lastly, you may also consider changing your font sizes for Legend items, the Title or 

the Scalebar if you think they are too small or too big. After you‟ve experimented, 

your final map should resemble the image below. Once you are satisfied with the 

result, you can complete the final step and export it. 
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4. Export your final map to the workspace directory by selecting {Export as 
image...} from the [Composer] menu (see next image). Name your map, 
“Australia – Temperature Forecast 20140717”. 
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Note: This menu provides the option of exporting your map, as it is presented in the 

Composer, to an image format of your choice (e.g. jpeg, bmp, tiff, png, etc.). Maps 

may also be exported as PDF documents by using the {Export as PDF...} option. 

When completed, do the following: 

 

1) Save the Map Composer project. 

 

2) Return to the main QGIS window and save the QGIS project via the 

[Project] menu. 

 

3) Visit your workspace and open the saved map to view it. 

 

1.8 Summary 

 

Completion of this exercise should provide you with very basic knowledge about 
map generation in QGIS. However, you should bear in mind that QGIS provides 
several alternative pathways for accomplishing many of the tasks illustrated. 
You should also be aware that QGIS possesses significantly more 
functionalities than demonstrated in this exercise as well as the previous 
exercises.  
 
With some review of these exercises and more practice you will gain comfort 
with performing the following tasks in QGIS: 
 

 Importing and removing data layers 
 

 Manipulating data layers using basic map tools (i.e. the zoom and pan tools) 
 

 Investigating the properties of vector and raster data 
 

 Obtaining basic information from data features using the Identify tool and/or 
the attribute table  

 
 Executing basic selection methods with the attribute table and the selection 

map tool 
 

 Creating subset data for vectors and rasters 
 

 Working with data in different coordinate systems and projection 
 

 Imposing basic style/appearance changes on the different types of spatial 
data with respect to fonts, sizes, colours and alignment  

 
 Designing and exporting a basic map from imported data 
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Practise using the raster and vector data provided for the workshop to create a 
map of your choice that focuses on your home country. 

 

 

 


